报错信息

webpack-dev-server --inline --progress --config build/webpack.dev.conf.js

报错原因

1 ) . 可能是因为node_modules有意外改动,导致依赖库不完整

2 ) . 新版webpack存在的BUG,构建项目所用的插件版本太低

解决方案

方案一 考虑是webpack版本问题

1 ) . 卸载当前版本:cnpm uninstall webpack-dev-server

2 ) . 安装指定版本:cnpm install webpack-dev-server@2.9.1

3 ) . 最后执行:cnpm run dev

还是报错,移步方案二 ↓ ↓ ↓ ↓ ↓ ↓


方案二

1 ) . 删除项目目录下的node_modules,终端执行:cnpm install

2 ) . 接着执行:cnpm run build

3 ) . 最后执行:cnpm run dev